Trailblazer Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
29 Posts
Assuming you've already wiped off and/or cleaned the lens, I'd suggest taking an extra close look at the camera itself to make sure the lens isn't cracked. I've had that happen on past vehicles, but the backup camera on the TB is neatly tucked away specifically to deter that from happening. That being said, if it is cracked, you'll have to either take it to the dealer or go old school and research the part numbers and such.

Hope that helps.
 

·
Registered
2021Trailblazer RS AWD Scarlet Red Metallic
Joined
·
1,072 Posts
That's not normal. Maybe some water got into the camera? If cleaning the camera doesn't improve the picture take it to the dealership.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
It is 8" display and here is a picture. the dealer said there is nothing wrong with it but I NEVER had a back up camera so faint. I could not figure out how to add the picture.
 

·
Registered
2021Trailblazer RS AWD Scarlet Red Metallic
Joined
·
1,072 Posts
The 8" display is the HD version and should have a clear picture. You can add a picture here by selecting the picture icon (looks like mountains with the sun) and then add a picture from your phone. I also have the 8" display and my view is nice and clear.

Here is what mine looks like.
442
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top