Trailblazer Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I ha e the check engine light on for the 2nd time since my purchase on Feb. 12. First time at 500 miles for a emission valve. Now have to take it back at 1500 miles. Ridiculous! I wanted one of these new Trailblazers so bad, and now I'm not so sure! Anyone else's thoughts? Making appt in the morning for service
 

·
Registered
2021Trailblazer RS AWD Scarlet Red Metallic
Joined
·
979 Posts
The problems I'm seeing vary alot with most of it being nothing major. We've had our RS almost a year now and haven't had any "real" problems just some warning msgs that software updates fixed. It's very helpful when owners like you share your experiences with everyone else so we can learn what problems are popping up and what to keep an eye out for. The 2021 Trailblazer is a new model in it's first year, so unfortunately things are going to come up. Please report back what they find this time and hang on there it's still a good vehicle, just needs some bugs worked out.
 

·
Super Moderator
2021 TB Zues Bronze Activ
Joined
·
660 Posts
I will second the thought that we all have bought 1 run vehicles. We are sorta the ginnea pigs for this car where in a few years the stuff we see will be worked out. Most things being seen are things that are programming issues. I have had mine a year this June and other then two fleeting messages ours has been fine. I say have patience and don't give up on this TB just yet. Most any new car any brand has issues new. You don't cars in all the dealer repair shops there to get a good wash job and sent on their way.
 

·
Registered
2021 Trailblazer Activ Zeus Bronze Metallic (+ 2016 Cadillac CT6 3.0TT Platinum)
Joined
·
96 Posts
At nearly 16k miles, I have encountered zero issues except for a small piece of rubber trim popping out of place during very high cross-winds (easily fixed on the roadside). I have gotten no error messages and have not experienced any odd noises or behaviors with the TB so far.
 

·
Super Moderator
2021 TB Zues Bronze Activ
Joined
·
660 Posts
At 12k miles have had one small coolant line to the turbocharger I think it was spring a leak. Two one off warning lights for service chassis and my wife says something about the 4x4 system. Only thing that comes and goes in the popping sound from the radio/speakers which seems to be something a hand full of folks have had also.
 

·
Registered
Joined
·
1 Posts
My girlfriend just bought her new Trailblazer this past Saturday and we had to have it towed back to the dealership with in an hour or purchasing it because it threw a p0700 code and wouldn't shift. The car had 54 miles on it when it happened.
 

·
Registered
Joined
·
3 Posts
I ha e the check engine light on for the 2nd time since my purchase on Feb. 12. First time at 500 miles for a emission valve. Now have to take it back at 1500 miles. Ridiculous! I wanted one of these new Trailblazers so bad, and now I'm not so sure! Anyone else's thoughts? Making appt in the morning for service
We're having the same issue. 3,500 miles. The car is three months old and the check engine light is popping on. Not too happy about the fact that the dealership had no idea what it is that's causing it. The car is still at the dealership, day two and they are scratching their heads.
 

·
Registered
Joined
·
3 Posts
We're having the same issue. 3,500 miles. The car is three months old and the check engine light is popping on. Not too happy about the fact that the dealership had no idea what it is that's causing it. The car is still at the dealership, day two and they are scratching their heads.
do you know what code was showing ? mine had a 0521 ends upthey the had service bulletin for oil pressure poor splice connection or oil sensor or the oil pump its self 2021 TB
 

·
Registered
2021 LT AWD
Joined
·
18 Posts
Not that it helps anyone having issues, but I'd like to chime in that at just over 10k miles I've had no significant issues. I had my plastic jack taken and get the brake squeal in reverse sometimes, but nothing other than what everyone on here has also complained of. They're not all bad!
 

·
Registered
Joined
·
3 Posts
do you know what code was showing ? mine had a 0521 ends upthey the had service bulletin for oil pressure poor splice connection or oil sensor or the oil pump its self 2021 TB
do you know what code was showing ? mine had a 0521 ends upthey the had service bulletin for oil pressure poor splice connection or oil sensor or the oil pump its self 2021 TB
 

·
Registered
Joined
·
3 Posts
Any trailblazer that was delivered before April 30th of 21 should have had service bulletin A202302140 done had code 0521 popping up oil pump had to be replaced
 
1 - 11 of 11 Posts
Top