Trailblazer Forum banner
21 - 22 of 22 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #21 ·
Hi there, I saw your post and I recently purchased a 2021 TB with 300 miles back in August. I now have 5K and last week it started doing the same thing as you explained.No forward collision, lane keep, adaptive cruise, the buttons don't even do anything when I press them. All was working great, and just stopped. I have checked for updates and there is none. I have removed my toll tag that was under my rearview mirror thinking that was the issue. Still, no fix, and the dealership I spoke with told me to drop it off but couldn't give me a time frame and they told me they had no rentals available and this is my only vehicle, hoping someone has found a fix.....or do I just need to take it in and rent a car? Hate that I am paying for a car with all these excellent features that don't work.

Sarah
Still have not been able to take mine in yet so if you would be so kind as to report back with what they find that would be great.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #22 ·
So here's the update. I took it back to Camping World and they said that there is nothing wrong with the battery disconnect and they have done thousands of them. They would remove it if I wanted but they would charge me to put it back the way it was, which I'm not even mad at because that's perfectly reasonable. I had someone I trust as a mechanic look at it and they also said that there is nothing wrong with the battery disconnect. I decided to take the car to a different Chevrolet dealer without removing the disconnect and see what they said. I dropped it off and about 2 hours later they called telling me that the front facing camera is bad and that there is a TSB about it and they need to order a new one. He told me the code but I was not somewhere I could write it down. In any event, a new camera is ordered and should be here by Monday. They also found that the pump for the washer fluid is leaking. All covered under warranty and I am hoping it will be back up and running sometime next week. Will update again once resolved... hopefully!
 
21 - 22 of 22 Posts
Top