Trailblazer Forum banner
1 - 10 of 10 Posts

·
Super Moderator
2021 TB Zues Bronze Activ
Joined
·
751 Posts
Discussion Starter · #1 ·
Wife got Service AWD message today in the DIC. She just scrolled out of the screen back to the MPH readout, no further errors see, I drove it tonight, seemed fine. BUT when I hit the AWD button to turn it on it flashed 3 or 4 times and went out. I seem to recall the green light stayed on when you had AWD engaged. When I turned it off the light flashed 2 times and back out. Can anyone confirm my flashing lights on that button are wrong?
Also when I turn it on I can hear a click from under the TB.
 

·
Registered
Joined
·
90 Posts
Wife got Service AWD message today in the DIC. She just scrolled out of the screen back to the MPH readout, no further errors see, I drove it tonight, seemed fine. BUT when I hit the AWD button to turn it on it flashed 3 or 4 times and went out. I seem to recall the green light stayed on when you had AWD engaged. When I turned it off the light flashed 2 times and back out. Can anyone confirm my flashing lights on that button are wrong?
Also when I turn it on I can hear a click from under the TB.
It's not working ... I'd take her in ASAP.
 

·
Super Moderator
2021 TB Zues Bronze Activ
Joined
·
751 Posts
Discussion Starter · #3 ·
I have an oil change sat set up but late in day they say they will try to see any codes but that will be it.
 

·
Registered
Joined
·
90 Posts
I have an oil change sat set up but late in day they say they will try to see any codes but that will be it.
A flashing light is a signal of trouble in the All-Wheel-Drive system. When flashing the system is disabled and not functioning. This might be caused by a poor electrical connection, failed motor or actuator or perhaps a failed control module.
 

·
Super Moderator
2021 TB Zues Bronze Activ
Joined
·
751 Posts
Discussion Starter · #5 ·
Now the flashing light is on the button to turn it off and on, not displayed in the DIC.
 

·
Super Moderator
2021 TB Zues Bronze Activ
Joined
·
751 Posts
Discussion Starter · #7 ·
it does it every time I turn it on. Seems to be coming from bottom of the TB. That said it may have been doing it all the time I just never listed for it since there were no warning lights till now and I am listening for anything that seems out of place. I suspect there prob is an issue since the light on the button does not stay on when I turn on the AWD.
 

·
Super Moderator
2021 TB Zues Bronze Activ
Joined
·
751 Posts
Discussion Starter · #8 ·
Wife drove the TB today. I checked it out when I got home. All is well now. Light flashes when turned on and stays on, goes off as expected when shut off. The Clicking noise is gone now also, just a small gear motor engagement sound that I have always heard. Hope there is a code to show what happened.
 

·
Registered
Joined
·
20 Posts
Wife got Service AWD message today in the DIC. She just scrolled out of the screen back to the MPH readout, no further errors see, I drove it tonight, seemed fine. BUT when I hit the AWD button to turn it on it flashed 3 or 4 times and went out. I seem to recall the green light stayed on when you had AWD engaged. When I turned it off the light flashed 2 times and back out. Can anyone confirm my flashing lights on that button are wrong?
Also when I turn it on I can hear a click from under the TB.
A flashing AWD light is usually a sign of some sort of problem with the system. I have the 2022 Trailblazer RS AWD and as long as you're not going over 45 mph, it will engage. The AWD light flashes 2-3 times on the dash and then remains illuminated and were it said 2WD, now says AWD.

I would definitely take it back to the dealership and have it checked out. Hope this helps👍
 

·
Super Moderator
2021 TB Zues Bronze Activ
Joined
·
751 Posts
Discussion Starter · #10 ·
Got the oil changed. There was a TSB for a module of some sort at the rear end part of the awd. Just a software update fixed it.
 
1 - 10 of 10 Posts
Top